Channelflow 2.0

About the Installation category

Questions and discussions related to installing channelflow, e.g. downloading, git, build system, required libraries.

Hey all,
It is my first time to use Channelflow ,but I install this so many times and failed .
I install this follow the installation steps from github’s installation.

mkdir build
cd build
cmake PATH_TO_SOURCE -DCMAKE_BUILD_TYPE=debug (/release) (configuration options)
make -j
make install

Here is my command line:
cmake /home/sunny/ykl/channelflow -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/home/sunny/ykl/channelflow2.0 -DWITH_PYTHON=ON -DWITH_HDF5CXX=ON

but it didn’t work.
cmake: /usr/local/lib/libcurl.so.4: no version information available (required by cmake)

– configuring channelflow version 2.0.2
– Using GNU compiler options

– Starting system introspection
– Found FFTW
– FFTW_LIBRARY=/usr/lib/x86_64-linux-gnu/libfftw3.so
– FFTW_OMP_LIBRARY=/usr/lib/x86_64-linux-gnu/libfftw3_omp.so
– FFTW_MPI_LIBRARY=FFTW_MPI_LIBRARY-NOTFOUND
CMake Warning at cmake/Modules/FindFFTW.cmake:32 (message):
The locations of fftw_mpi and fftw library are not the same. This is
probably something you don’t want!
Call Stack (most recent call first):
CMakeLists.txt:102 (find_package)

– MPI libs: /usr/lib/openmpi/lib/libmpi_cxx.so;/usr/lib/openmpi/lib/libmpi.so
– FFTW_MPI library: FFTW_MPI_LIBRARY-NOTFOUND
CMake Error at CMakeLists.txt:125 (message):
Option USE_MPI is set and MPI is found, but cmake couldn’t find
libfftw_mpi, which is required. If you do not want to use MPI, clean up
and rerun cmake with -DUSE_MPI=off.

– Configuring incomplete, errors occurred!
See also “/home/sunny/ykl/channelflow/build/CMakeFiles/CMakeOutput.log”.
See also “/home/sunny/ykl/channelflow/build/CMakeFiles/CMakeError.log”.

I tried many times ,but i don’t know how to fix it.I use the linux not well ,because I use the windows system all the time.maybe the problem is easy to solve ,I think that is differences in profession makes one feel worlds apart.
I am looking forward to your reply.
-kalon

Hi,
add FFTW path to cmake using -DCMAKE_PREFIX_PATH cmake flag
the following worked for me:

mkdir build
cd build
cmake ../channelflow -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$HOME/opt/channelflow -DCMAKE_PREFIX_PATH="/home/ssray/opt/fftw/3.3.8;/home/hemanta.kumar/opt/netcdf_c/4.6.3;/home/hemanta.kumar/opt/hdf5/1.10.5" -DCMAKE_CXX_COMPILER=/share/openmpi/bin/mpicxx